1. Chris
  2. General Nephrology Questions
  3. Sunday, 16 February 2020
  4.  Subscribe via email
I am 40 years old otherwise healthy guy and went to the Dr initially for what seems like a UTI but I tested negative for. Took a battery of Sti test and all negative. They did a urinalysis and I had elevated creatinine levels. First test was 128 umol/l. I told the Dr I am on a high protein diet due to working out. Currently weight 204 so eat between 170-200grams of protein daily. I was also using creatine supplements. Globular filtration was 60ml. We did another test a week or do later. I stopped with the creatine and this time was 111umol/l and globular filtration 71ml. He wanted to do a 24 hour itinerary test next. We waited a few weeks and did that. During that time I still worked out but cut out creatine all together and dropped protein to 165 grams per day. 24 hour creatinine showed 23.9 mmol/d and the volume showed 2700ml per day. I do on average drink a gallon of water daily and didn’t stop that for the test. These result register as abnormal barely but seem consistent. Does it seem like my kidneys are in trouble? Could the infection I initially went in for which is still unresolved be playing a role?
Responses (0)


There are no replies made for this post yet.
Be one of the first to reply to this post!
Guest
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below. Supports gif,jpg,png,zip,rar,pdf,jpeg,doc,docx,xls,xlsx
• Insert • Remove Upload Files (Maximum File Size: 10 MB) - NB: PLEASE REMOVE ALL IDENTIFYING DATA
ukidneyisup